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Tutorial 4: Working with Multiple Data Groups on a Form

Introduction

This tutorial shows you how to enable multiple data groups on a FlukeView
Forms form template, and how to customize a form template to display data
from multiple meters on a single form. The tutorial also shows how meter
data can be copied from one form, and pasted to another.

Tutorial

Beginning with FlukeView Forms 2.0, you can display meter data from more
than one meter on a single form. This allows data collected from separate
meters, or from the same meter at different times, to be compared side-by-
side on a form.

To differentiate between data collected from different meters, a data group is
associated with each "meter’s worth” of data that you transfer to a form.
When transferring meter data to the form, you specify a data group to
associate with the data. Form items that display meter data are set to a
particular data group, and display the meter data corresponding to that data

group.

To display multiple data groups on a form, the form template you use must
be enabled for multiple data groups. Otherwise, the form can only contain
data from a single meter. FlukeView Forms Designer is used to enable
multiple data groups on a form template.

All form templates contain form items, which are the fields that display meter
data or user data. In this tutorial, the term “form item” is generic; text
enclosed in angle brackets refers to a specific form item. For instance, a
logging summary form item will appear in the text as <logging summary>.

Note

Some basic familiarity with FlukeView Forms Designer is
assumed. Please step through Tutorial 1: Creating a Customized
Form Template before using this Tutorial if you have not used the
Designer before.

Examine the Form Template
1. From the Windows Start menu, open FlukeView Forms.

2. The path name of the database that you are currently using is shown in
the brackets in the blue title bar at the top of FlukeView Forms.
Remember this path name; you will be changing to a different database
for this tutorial, and will want to return to this database when you are
finished.
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From the File menu, select Open Database. Browse to the directory where
FlukeView Forms is installed. Open the database tutorial.fdb, which
contains the form template you will be enabling for multiple data groups.

From the Tools menu, select Options. When the Options dialog box
appears, select the Preferences tab. Make sure Copy latest meter data
when changing form templates and Open a saved form when changing
form templates are not checked (this would cause different behavior
during this tutorial.)

From the File menu, select New Blank Form. Select the form template
Tutorial 4 - Single Data Group Form and click OK to open.

This form template is not enabled for multiple data groups; it cannot contain
more than a single meter’s worth of data. It contains several form items,
including a <logged readings graph>, a <logging summary>, and a <logged
readings table>.

1.

From the File menu, select Open Saved Form. Notice that in the Open
Saved Form dialog box, under the Tutorial 4 - Single Data Group Form
entry, there are two saved forms listed. Select the one with the
description “Light Sensor on a Clear Day”, and click OK.

You are now viewing a saved form which shows a logging session where a
meter was used to log the output from a light sensor over a day. Notice
that the data is displayed in PPF units; scaling has been applied to the V
DC units measured by the meter. The scaling factor is described in the
<logging summary> form item on the form, adjacent to “"Scaling”. (You
can set, change or eliminate the scaling factor by selecting Scale Logged
Readings under the Tools menu.)

Select Open Saved Form again from the File menu again, and select the
saved form under the Tutorial 4 - Single Data Group Form entry with the
description “Light Sensor on a Cloudy Day”. Click OK.

Notice that the <logged readings graph> displays a much “nosier” trace,
indicating that the readings were more varied than those displayed in the
other saved form.

Instead of having to save these two logging sessions on two separate saved
forms, it would be preferable to save them on a single form. We will do this
by enabling this form template for multiple data groups.

Enable the Form Template for Multiple Data Groups

1.
2.
3.

From the File menu, select Exit to leave FlukeView Forms.
From the Windows Start menu, open FlukeView Forms Designer.

From the File menu, select Open. Select the form template Tutorial 4 -
Single Data Group Form.

From the Layout menu, select Data Groups. The Data Groups dialog
appears.

Click on Enable display of more than 1 meter’s data on the form so that it
is checked. This will enable this form template for multiple data groups.
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10.

Under Data Group List, 8 different data groups are listed. Only those that
are checked are enabled. The colors associated with each group are
important; form items associated set to display this data group will be
tagged with the data group color and number. Also, <logged readings
graph> form items will draw the readings using the color associated with
the data group they are displaying.

Make sure only Data Groups 2 and 3 are checked; uncheck any others.
Then click on the OK button.

The Undefined Data Groups dialog box appears. Since this form template
was created without multiple data groups being enabled, none of the form
items on this form have been set to display a specific data group.

Select Data Group 2 (the data group with the red color) under Data Group
To Display, and click on the OK button. This will set all the existing form
items on to display data associated with Data Group 2 (and not the other
enabled data group, Data Group 3).

Notice that many of the form items on the form, such as the <logged
readings table> and the <logging summary>, now display a red shaded
"(2)”, indicating that by default they will display data group 2.

Now we will save this as a new form template, "Two Data Group Form”.

1.

At the top of the page is a <label> displaying the text “Tutorial 4 - Single
Data Group Form”. Move your cursor over the <label> and right-click on
it. A border will appear around the <label>, and a pop-up Properties
menu appears. Select it.

The tabbed property dialog box appears. Under the General tab, change
the Label text from “Tutorial 4 — Single Data Group Form” to "Two Data
Group Form”. Click OK.

From the File menu, select Save As.
In the Form template name: box, type in Two Data Group Form. Click OK.

From the File menu, select Exit.

Copy Meter Data to the Form
You could now transfer data from a meter (or meters) to the new form
template you just created. For the sake of this tutorial, we will instead copy
data from existing saved forms into the template.

1.
2.

From the Windows Start menu, open FlukeView Forms.

From the File menu, select Open Saved Form. Select the saved form under
the Tutorial 4 - Single Data Group Form entry with the description “Light
Sensor on a Clear Day”. Click OK.

From the Edit menu, select Copy Form Data. This will copy the meter data
from this form into the clipboard.

From the File menu, select New Blank Form. Select the new form
template you just created, Two Data Group Form, and click OK to open.

From the Edit menu, select Paste Form Data.
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6. The Paste Form Data dialog box appears, because you need to select
which data group to associate with the meter data you are pasting into it.

7. Under To, select Data Group 2 (which displays the red shaded “(2)"”). This
is the data group you set the form items on this template to display. This
will associate the “clear day” data you just copied with Data Group 2. Click
OK.

8. The data is copied to your form. Also, the Paste Form Data dialog box

appears again, asking if you want to copy the same meter data to the
other data group on the form template, Data Group 3. Since you don't
want to copy the same meter data to the form twice, click Cancel.

Notice that the measurements taken on the clear day are displayed on the
various form items. Now let us copy the data from the cloudy day to this
form.

1.

First, we need to save the form we’ve been working on. From the File
menu, select Save As. Under Form Remark, type “Light sensor on 2 days”,
and then click the Save button.

From the File menu, select Open Saved Form. Select the saved form under
the Tutorial 4 - Single Data Group Form entry with the description “Light
Sensor on a Cloudy Day”. Click OK.

From the Edit menu, select Copy Form Data.

Now we’ll return to the saved form you just created. From the File menu,
select Open Saved Form. Select the saved form under the Two Data Group
Form entry with the description “Light sensor on 2 days”. Click OK.

From the Edit menu, select Paste Form Data. The Paste Form Data dialog
box appears again; this time, select Data Group 3 under To, and click OK.
When the dialog box re-appears, again click on Cancel - you don't want to
overwrite the meter data from the clear day that you previously copied
into the form.

Notice that the appearance of your form has not changed. This is because all
of your form items are currently set to display data from Data Group 2.
However, we can change which data group each form item displays in
FlukeView Forms at any time.

Let's change the <logged readings graph> to display Data Group 3 instead of
Data Group 2.

1.
2.

Right-click over the <logged readings graph>. A pop-up menu appears.

Select Select Traces/Groups. The Select Traces / Groups dialog box
appears.

Under Groups to show, select "Data Group 3”.

Under Traces, click on the “"Data Group 3" entry so that it is checked, and
then click OK.

The <logged readings graph> now displays the “cloudy day” data you
associated with Data Group 3 when you pasted it into the form.
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You can also change the data group being displayed by the <logging
summary>, <logged readings table> and <meter identification> in the same
way.

Now save the “Light sensor on 2 days” form so that it contains both data
groups.

1. From the File menu, select Save. The Replace current saved form (Save)
radio button should be selected, and the Form remark should be “Light
sensor on 2 days”.

2. Click on the Save button.

3. Notice that the Saved forms drop-down list box on the FlukeView Forms
toolbar (above the form) still shows 1 total saved form for this form
template. Using Save, as opposed to Save As, updated the saved form you
were working on, instead of creating a new saved form.

Customizing the Form Template for Two Data Groups
We've seen how form templates can be enabled for multiple data groups; and
how individual form items can be changed to display meter data associated
with different data groups. While this is useful for interactive viewing of data,
it doesn’t allow us to visually compare the two data logging sessions side-by-
side. And we still must print the form twice to have printouts of both logging
sessions, which is no improvement over the Single Data Group form template.

However, we can customize our new form template so that it contains form
items corresponding to both data groups. To do that, we’ll need to go back to
FlukeView Forms Designer and make some changes to the form template.
We'll add a second page to the template, move some of the form items from
the first page to the second page, and create new form items that are set to
display Data Group 3 instead of Data Group 2.

1. From the File menu, select Exit to leave FlukeView Forms.
2. From the Windows Start menu, open FlukeView Forms Designer.

3. From the File menu, select Open. Select the form template Two Data
Group Form.

4. From the Layout menu, select Number of Pages. A dialog box appears,
showing the current number of pages is set to 1.

5. Change the value in Number of Pages: from 1 to 2, and click OK.

Notice that now there is more room at the bottom of the form. A dotted line
shows the division between pages 1 and 2 of the form template.

We will move the tabular form items from page 1 to page 2, to provide more
room on page 1 for a second <logged readings graph>. For a description of
how to move and insert form items in FlukeView Forms Designer, please read
Tutorial 1: Creating a Customized Form Template before proceeding further.

1. First, move the <logging summary> from page 1 to the top left-hand
corner of page 2.

2. Move the other form items on page 1 to page 2 in a similar manner, with
the exception of the three form items at the top of page 1: the <logged
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readings graph>, the <label> displaying “"Two Data Group Form”, and the
<date time stamp> labeled “Form Last Modified”.

3. Keep the form items you’re moving in the same relative position to each
other that they had on page 1.

Now we'll create new form items to display Data Group 3.
1. Scroll back to page 1 of the form template.

2. Below the current <logged readings graph>, create a new <logged
readings graph> form item. This is done by selecting Insert Form Item
from the Edit menu, selecting FlukeView Logged Readings Graph, and
clicking on the Insert button. Click on the Close button to close the Insert
Form Item dialog box.

3. Move the new <logged readings graph> below the existing <logged
readings graph>, and resize it to the same general dimensions as the
existing graph. The new <logged readings graph> should take up most of
the blank space left at the bottom of page 1.

4. Right-click on the new <logged readings graph>, and select Properties on
the pop-up menu that appears.

5. Select the General tab on the FlukeView Logged Readings Graph
Properties dialog box that appears. Select the text in the Title box and
delete it. (We don’t want “FlukeView Logged Readings Graph” to appear as
the title of this <logged reading graph>.) Click Apply.

6. Select the Data Groups tab on the FlukeView Logged Readings Graph
Properties dialog box. This is where you select the default data group that
a form item will display.

7. Select Data Group 3 under Data Group to Display, and click OK.

The new <logged readings graph> will now display Data Group 3 instead of
Data Group 2, allowing you to view graphs of both logging sessions on
page 1.

Now scroll down to page 2, and create new <logging session>, <logged
readings table> and <meter identification> form items. Move each one to the
bottom half of page 2, matching the same relative positions and size as the
existing form items in the top half of page 2.

Note that each form item you create is already set to display Data Group 3;
you don’t need to specifically set each form item to Data Group 3 via the
properties dialog box. FlukeView Forms Designer remembers the data group
you set the last form item to, and uses it as the default data group for any
newly-created form items.

Now save these changes as a new form template, “Logging Session
Comparison Form”.

1. Change the text displayed in the <label> at the top of page 1. Move your
cursor over the <label> at the top of page one and right-click on it. A
border will appear around the <label>, and a pop-up Properties menu
appears. Select it.
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5.

The tabbed property dialog box appears. Under the General tab, change
the Label text from “Two Data Group Form” to “Logging Session
Comparison Form”. Click OK.

From the File menu, select Save As.

In the Form template name: box, type in Logging Session Comparison
Form. Click OK.

From the File menu, select Exit.

Compare Two Logging Sessions
Now we’ll view the two logging sessions side-by-side. We'll copy the meter
data from your first multiple data group form to your new “Logging Session
Comparison Form” form template.

1.
2.

From the Windows Start menu, open FlukeView Forms.

From the File menu, select Open Saved Form. Select the saved form
under Two Data Group Form entry with the description “Light sensor on 2
days”. Click OK.

From the Edit menu, select Copy Form Data. This will copy all the meter
data on the form (both data groups) to the clipboard.

From the File menu, select New Blank Form. Select the new form
template you just created, Logging Session Comparison Form, and click
OK to open.

From the Edit menu, select Paste Form Data.

The Paste Form Data dialog box appears. Make sure that Data Group 2 is
selected in both the Paste Meter Data From and To. Then click OK.

The “clear day” data is copied to your form.

Now the Paste Form Data dialog box appears again, asking if you want to
copy the other, “clear day” meter data the form. Make sure that Data
Group 3 is selected in both the Paste Meter Data From and To. Then click
OK.

Your form now displays both logging session side-by-side — graphically on
page 1, and in tabular format on page 2.

Note

The Y-axis scale of the <logged readings graph> may be different
for the two data groups. You can fix this by setting the maximum
and minimum Y-axis values in the Manual Zoom dialog. Set the
Y-axis Manual Zoom values of one <logged readings graph> to
match those of the other <logged readings graph>.

Now save the form.

1.
2.

From the File menu, select Save As.

Under Form Remark, type "Light Comparison”, and then click the Save
button.
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Finish Tutorial
You have finished the tutorial, and should return to your own database. From
the File menu, select Open Database, and select the database you were using
before you started this tutorial.

Notes

See Also

When you are transferring meter data to a form template that has been
enabled for multiple data groups, you will be prompted for the data group
to associate with the meter data.

When interactively logging to a form template that has been enabled for
multiple data groups, you need to specify the data group to associate the
logged data with on the Logging Window under Setup. Specify the data
group to associate with the logged data under Log to Data Group.

Data groups names (by default, “"Data Group 1”, “"Data Group 2", etc.) can
be customized for a particular form template. This can be done in the Data
Groups dialog box in FlukeView Forms Designer, using the Rename
button.

Beginning with FlukeView Forms 2.1, a single <logged readings graph>
form item can now display traces from multiple data groups. To do so,
bring up the Select Traces / Groups dialog box for the <logged readings
graph> in FlukeView Forms. Under Groups to show, select one of the
entries that begins with “Any group...”, rather than a specific data group.
Traces from more than one data group will then be displayed under
Traces; select the ones you wish to display on this group.

To copy the “Logging Session Comparison Form” form template you
created to your own database, please see Tutorial 1: Creating a
Customized Form Template. There is a section at the end of the tutorial
that explains how to do this.

FlukeView Forms Users Manual, “Data from Multiple Meters on a Single
Form”
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