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Managing FlukeView® Forms Databases

FlukeView Forms Technical Note

Thistechnical note answers frequently asked questions about managing the data stored in a
FlukeView Forms database. It discusses what is kept inside a database, and provides tips on
managing your FlukeView Forms databases. It shows you how to copy data between databases.
And it describes how you can send forms with data on it to other people, inside or outside of
your company.
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What iskept in a FlukeView For ms database?

Simply put, all your data. Each time aform is saved in FlukeView Forms, al of the data stored
on the formis saved to the currently selected database.

Specifically, when aform is saved, the following datais saved:
» Meter Data: data from the meter that is uploaded, logged, or copied to the form.

» User Data: Datatyped into the form; for example, a comment typed into a memo field.
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=  Formltem Settings: Various settings made to graphs, tables or other form items on the form
to format the way the data is displayed. For instance, the zoom factors or trace selections for
the graphs; or the data groups being displayed by the tables.

» Saved FormInfo: When saving a form, you’re asked foFarm remark — a comment about
the data saved on the form. These remarks, along with the date you initially saved the form,
are stored in the database, and are used (along with the form template the saved form is based
on) to retrieve and view the saved form later.

The saved form is the key to viewing data you've saved to the database CpeteSaved
Form... from the File menu, and find the remark and save date in the Open Saved Forndiaog
that corresponds to the saved form you want to view.

Y ou can a'so use the Find tool to search the database for a particular saved form. Thisis helpful
when you have many saved formsin your database. Y ou can search for saved form remarks, the
date the form was initially saved, or text typed into the form itself (user data).

Besides data, the only other thing that's saved in the database is the form templates — “blank”
forms containing no data, which you create a new form with, and then add data to and save. You
initially select a form template that will display the data the way you want (i.e., with or without
graphs, tables, comment fields, etc.). After choosing the form template, data may then be
transferred to the form. (For example, the “Generic Logging Form” form template is frequently
used for displaying logged readings.)

Form templates can be modified or created using the FlukeView Forms Designer program, and
can be exported and imported to form template files. For details, sEkikie¥iew Forms

Tutorial 1: Customizing Form Templates from the FlukeView Forms Help Menu, CD, or the
FlukeView Forms support pagzhatp://www.fluke.com/flukeviewforms/

Which databaseam | currently using?

FlukeView Forms and FlukeView Forms Designer always displays the pathname of the currently
open database in the blue title bar — in brackets, following “FlukeView Forms”. By default, all
FlukeView Forms databases have file extensibdb; e.g., t ut ori al . f db”.

Whenever FlukeView Forms (or FlukeView Forms Designer) is started, the database that was
previously used is opened automatically. So, unles®geu a different databg:ar create a
new databasegou will continue to use the same database every time you run FlukeView Forms.

When FlukeView Forms is installed, the default databaseaeypl e. f db”. Sanpl e. f db
contains saved forms with sample data, and is intended to provide examples of typical ways that
FlukeView Forms can be used to retrieve and display data.

After usingsanpl e. f db to become familiar with FlukeView Forms, it's a good ide:ar&ate
new databaseand use them insteaddnpl e. f db. Storing all of the data you collect into a
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single, ever-growing database can lead to poor performance and clutter. Instead, store your data
in several smaller FlukeView Forms databases, with similar data stored together.

How do | create a new FlukeView For ms database?

You can create a new FlukeView Forms database in FlukeView Forms Designer.
1. If FlukeView Forms is running, close the application.
2. Open FlukeView Forms Designer.
3. From theFile menu, seledNew Database.. The New Databasedialog will appear.
4. Typeinthe name of the new database you wish to create. (new. f db isthe default.)
5. Click on the Savebutton.

A new FlukeView Forms database will be created with the filename you provided. The next time
you start FlukeView Forms, the new database will automatically be opened.

The new database is created with no saved data, and only the generic form templates. Y ou can
copy saved forms or form templates from other databases to your new database, if you wish.

How do | use a different database in FlukeView Forms?

Once you have created several FlukeView Forms databases (perhaps assigning a separate
database to each of your clients, or to separate projects or tasks), how do you select which
database you want to use in FlukeView Forms?

1. From the File menu, select Open Database.. The Open Databasedialog will appear.
2. Browse and select the database you wish to open. Click on the Open button.

3. The New Blank Form dialog will appear. Select the form template you wish to display.
(Y ou can always change the form template later, by selecting New Blank Form... from
the File menu, or by selecting aform template from Select a form:on the FlukeView
Forms toolbar.)

The database you selected will become the default database from now on, until you open a
different database, or create a new one.

A shortcut: the names of the last four FlukeView Forms databases you've used are listed at the
bottom of the~ile menu. Select any of these database names will open that database.
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How do | copy aform template from one database to another?

When youcreate a new databaike database contains no data, and only the default form
templates. You may want to use a form template contained in a different database for creating
forms in your new database. For example, you might want to u3érteeMeter Sample form
template in thesanpl e. f db in your new database.

However, a form template is only available for use if it is stored in the database that is currently
open; andrhree Meter Sample is only insanpl e. f db. So the form template must be copied
fromsanpl e. f db to your new database:

1. If FlukeView Forms is running, close the application.

. Open FlukeView Forms Designer.
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3. Open the databas®ntaining the form template you wish to copy. (Esgnpl e. f db.)
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. From theFile menu of FlukeView Forms Designer, sel®gten... The Open Form
Template dialog appears.

5. Select the form template you wish to copy and click on the OK button. The form
template you selected will be displayed in FlukeView Forms Designer.

6. From the File menu, select Export... The Export Form Template dialog will appear.

7. Typein anew filenameto save the form template in. Click on the Savebutton. This
creates a new form template file (with file extension . f t f ), containing only the file
template you are currently displaying.

8. Now select Open Database..from the FlukeView Forms Designer File menu. The
Open Databasedialog will appear.

9. Select the database you wish to copy the form template into (in this example, the new
database), and click on the Open button.

10. Select Import... from the File menu. The Import Form Template dialog appears.
11. Select the form template file you just created, and click on the Open button.

12. The form template is copied into the database. Y ou still need to name the form template
and save it into the database; do this by selecting Save As...from the File Menu.

Y ou can now use this form template to create formsin your new database.

Note: when you copy a saved form from one database to another, the form template associated
with the saved form is auiomaticaiiy copied as weli. Thisis aciualy asimpler way of copying a
form template from one database to another, but it also copies data along with the template.
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This operation, alag with other brm template degn procedures, cdre found n FlukeView
Forms Tutorial 1. Customizing Form Templates from the FlukeVew Forms Help Menu, CD, or
the FlukeView Forms support pagehép://www.fluke.com/flukeviewforms/

How do | copy data between FlukeView For ms databases?

Beginning with FlukeView Forms version 2.1, there are twaysvto cy databetween
databases:

1. Copy an entire saved form fronme datdéase to anotheAll the meter datayped-in user
data and form item settys of the saved form will be copied (afpwith the associated
form template, if necessg into either an existopdatabase.

Alternativdy, the saed form can be caed into a nevdatabae, containig ony the
saved form and its form template.

2. Copy only the metedata from a saved form in anotldatabae. This is useful wheyou
wish to cgy meter data saved in a different datgbato the fom you are arrenty
viewing in FlukeView Forms.

These two methods of pging data are dgcribed below.

How do | copy a saved form to another FlukeView For ms database?

Beginning with FlukeView Forms 2,lyou can cpy an entire saed form into anothedatabae,
or into a new dataase. he entiresaved brm — including theneter d#a stored in thedrm, the
user datdyped into thedrm, and thedrm item settings — will be duplicated the form

template associated with the saved form does not exist in get ta@abase, it will be copied as
well.

To cqpy a saed form to anothenasting databse, or to a new dalbase:

1. In FlukeMew Forms,open the d@abasecontaining the saved foryou wish to cpy.

2. SelectOpen Savedrorm... from the File menu. The Open Savedrorm dialog will
appear.

3. Select the saved form you want to copy. Click on the OK button. The saved form will be
displayed.

4. Select Export Form... from the File menu. The Export For m to New or Different
Databasedialog will appear.

a If you want to copy the saved form to an existing FlukeView Forms database,
select the existing database in the dialog box.

5


http://www.fluke.com/flukeviewforms/

FlukeView Forms Technical Note Managing FlukeView® Forms Databases

5.

b. If you want to create a new database, containing only the saved form (and its
associated form template), type in a new file nantélimname:.

Click on theSave button.

The saved form has been copied to the database you specified.

How do | copy meter data from one FlukeView Forms database to another?

Beginning with FlukeView Forms 2.1, you can copy the meter data from a saved form in another
database into the form you are currently displaying. This is useful when you wish to compare
data you've stored in a different database to data you're currently evaluating — particularly when
you're using a template that has been enabled for multiple data groups. (For more details on
multiple data groups, see tRtukeView Forms Tutorial 4: Working with Multiple Data Groups

on a Formfrom the FlukeView Forms Help Menu, CD, or the FlukeView Forms support page at
http://www.fluke.com/flukeviewformsy

1.

In FlukeView Forms, display the form you wish to copy the meter data to. It can be a new
blank form (i.e., a form template), or a saved form that already contains some data.

Selectimport Form Data... from the Edit menu. The Import Form Data From
Databasedialog will appear.

Select the database containing the meter data you want to copy. Click on the Open
button.

The Import Form Data From Databasedialog will appear. Thisis similar to the Open
Saved Formdialog; select the saved form containing the meter memory you want to

copy.

If the saved form you selected and/or the form you are currently viewing is enabled for
multiple data groups, adialog will appear asking you to specify:

a. The data group associated with meter data you wish to copy from the saved form
in the other database.

b. The data group on the currently displayed form to copy the meter data to.

The dialog will reappear for each data group that is active on the currently displayed
form. If you don’t want to copy the meter data to other data groups on this form, simply
click on theCancel button.

The data has now been copied to the active form.
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How can | send a saved form in FlukeView Formsto someone else?

After you've placed meter data and your comments on a form, and then formatted and saved it,
you probably want to show it to other people — your customers or other people in your company,
for example.

In many cases, this can be done by printing out the form, and then mailing or faxing the printout
to the people concerned. However, what if you want to send it to someone electronically, via e-
mail? Or to someone who wants to analyze the data further, or wants to compare it with data
collected in other FlukeView Forms databases?

This can be done lgopying the saved form (or forms) to a new datab@seé sending it to the
intended audience. The new database will contain only the saved forms you want to distribute.

A FlukeView Forms database can be e-mailed, or copied to a CD-ROM or floppy disk. While it
may be large, there are ways to reduce its size for easier transport:

1. Open the database with FlukeView Forms DesignerQptamnize the database (select
Database Maintenance..from the Advancedmenu). Thiswill compact the database.

2. To further reduce the size of the database, use a program like ZIP or WinZIP to compress
the database. Data compression programs can dramatically reduce the size of a
FlukeView Forms database for transport.

If the people you are sending the database to do not own FlukeView Forms, they will not be able
to view the saved forms in the database. However, there is now a FlukeView Forms Demo
version available from Fluke, which can be used to view existing FlukeView Forms databases. It
isfree, and available for download from the FlukeView Forms web site at
http://www.fluke.com/flukeviewforms/.

The Demo version of FlukeView Forms cannot communicate with meters; all meter
communications components have been disabled. The commercial version of FlukeView Forms
must be purchased to transfer data from supported meters. The Demo version also does not come
with FlukeView Forms Designer.

However, the Demo version can be used to display, edit and print saved forms created with the
commercial version. It basically provides all the data display, formatting and printing capabilities
of the commercia FlukeView Forms software.
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